Guide Google Sheets COUNTIFS et COUNTIF pour 2022

Photo of author

By Julien

La fonction COUTIF Google Sheets peut être utilisée lorsque vous souhaitez obtenir une quantité lorsqu’une certaine condition est remplie.

Par exemple, si vous avez une liste d’étudiants et que vous souhaitez obtenir rapidement le décompte de tous les étudiants ayant obtenu un score supérieur à 75, vous pouvez utiliser la fonction NB.SI dans Google Sheets.

Avant de vous montrer quelques bons exemples d’utilisation de la fonction NB.SI, passons rapidement en revue la syntaxe et quelques éléments importants à ce sujet.

Table des matières

Google Sheets COUNTIF SYNTAXE

=COUNTIF(intervalle, critères)

  • plage – plage de cellules à partir de laquelle vous souhaitez obtenir le nombre.
  • critère – une condition qui doit être remplie pour que la cellule soit comptée.

Le critère pourrait être :

  • Numéro.
  • une chaîne de texte telle que “Pomme” ou “Banane”.
  • référence de cellule (telle que A1 ou B1).
  • une expression telle que “=100” ou “>100” ou “<100". Notez qu'en cas d'égalité, vous n'avez pas besoin d'utiliser le signe égal. Vous pouvez utiliser le nombre entre guillemets.
Découvrir l\\\'article :  Utilisation de la fonction Google Sheets REGEXEXTRACT

Une plage de cellules peut contenir des nombres ou des chaînes de texte.

  • Si la plage contient des nombres, les critères peuvent utiliser des opérateurs de comparaison (>, <, =, <>). Par exemple, vous pouvez compter le nombre d’élèves ayant obtenu plus de 75 points dans une matière comme critère “>75”. La fonction vérifie chaque nombre dans la “plage” pour ce critère. Notez que lorsque vous utilisez l’opérateur avec un nombre, vous devez le mettre entre guillemets.
  • Si la plage contient des chaînes, le critère peut être une chaîne de texte entourée de guillemets (par exemple “Apple”) ou une référence de cellule qui contient la chaîne de texte.
    • Vous pouvez également utiliser des caractères génériques en relation avec des conditions de texte. Par exemple, pour compter les cellules contenant Apple ou des pommes, vous pouvez utiliser Apple* comme critère.

Examinons maintenant un exemple d’utilisation de la fonction COUNTIF dans Google Sheets.

COUNTIF exemples de fonctions Google Sheets

Voici six exemples d’utilisation de la fonction NB.SI dans Google Sheets.

Exemple 1 – Compter le nombre d’élèves ayant obtenu plus de 75 points

Supposons que vous ayez une liste d’étudiants avec des notes obtenues à un examen.

Fonction Countif dans Google Sheets - Exemple 1

Voici une formule qui vous donnera le nombre d’élèves ayant obtenu un score supérieur à 75.

=NB.SI($B$2:$B$14,“>75”)

fonction countif feuilles google

entrée:

  • La condition doit être entre guillemets.
  • Vous pouvez également ajouter une valeur conditionnelle à une cellule et utiliser cette référence de cellule. Si le critère est, par exemple, dans la cellule C2, vous pouvez utiliser la formule : =NB.SI($B$2:$B$14,“>”&C2). Lors de l’utilisation d’une référence de cellule, l’opérateur doit toujours être placé entre guillemets et inclus dans la référence de cellule à l’aide de &.

Exemple 2 – Calcul des valeurs dans Google Sheets pour les comptes de transaction

Supposons que vous disposiez des données de transaction indiquées ci-dessous :

informations sur les événements affichées dans le tableau

Voici la formule qui nous donne le nombre d’événements aux États-Unis :

fonction countif feuilles google

entrée:

  • Puisque le critère est le texte, il n’est pas nécessaire d’utiliser le signe égal. Par exemple, dans cet exemple, la condition est que le pays doit être égal aux États-Unis, vous ne pouvez donc utiliser que “USA”.
  • Le critère peut également se trouver dans une cellule. Dans ce cas, vous pouvez simplement utiliser une référence de cellule. Si le critère est, par exemple, dans la cellule D2, vous pouvez utiliser la formule : =NB.SI($B$2:$B$13,D2)

Exemple 3 – Compter tous les enregistrements sauf US à l’aide de la fonction COUNTIF de Google Sheet

Supposons que vous disposiez des mêmes données de transaction (utilisées dans l’exemple 3) et que vous souhaitiez compter tous les enregistrements de transaction à l’exception des États-Unis.

Découvrir l\\\'article :  OU Utilisez le didacticiel Google Sheets et des exemples pour 2022

les mêmes données d'événement qui apparaissent dans le tableau

Voici la formule qui fait cela :

=NB.SI($B$2:$B$13,“<>États-Unis”)

fonction countif feuilles google

La formule ci-dessus comptabilise toutes les transactions sauf celles dont le pays est “USA”.

Exemple 4 – Compter toutes les cellules vides/vides dans une plage avec la fonction NB.SI dans la syntaxe Google Sheets

Si vous avez un énorme ensemble de données et que vous souhaitez obtenir le nombre d’enregistrements manquants ou de cellules vides ou vides, vous pouvez utiliser la fonction NB.SI pour ce faire.

Supposons que vous disposiez de l’ensemble de données ci-dessous :

l'ensemble de données indiqué dans le tableau

Voici une formule qui vous donnera le nombre total de cellules vides ou vides :

=NB.SI(2 $ : 13 $,“”)

fonction countif feuilles google

Le critère utilisé dans cet exemple est “” (guillemets). Lorsque seuls les guillemets sont utilisés comme critères, seules les cellules vides sont prises en compte. Notez que s’il y a une cellule qui semble vide mais qui contient un espace, elle ne sera pas comptée par cette formule.

Exemple 5 – Compter toutes les cellules non vides d’une plage à l’aide de la fonction COUNTIF de Google Sheets

En prenant les mêmes données de l’exemple 4, cet exemple montre comment compter toutes les cellules non vides dans un ensemble de données.

les mêmes données de l'exemple 4 présentées dans le tableau

Voici une formule qui compte toutes les cellules non vides :

=NB.SI(2 $ : 13 $,“<>“)

Le critère utilisé dans cet exemple est “<>” (pas le même caractère entre guillemets). Ce critère signifie que les cellules ne sont pas égales à la chaîne vide. Notez que s’il y a une cellule qui semble vide mais qui a un espace, elle sera calculée à l’aide de cette formule.

Exemple 6 – Compter toutes les occurrences d’un mot-clé

Parfois, vous devrez peut-être traiter des données qui contiennent des variantes du même nom ou objet. Par exemple, les informations ci-dessous ont des variantes d’Apple comme Apple, Apples, Fruit – Apple.

fonction countif feuilles google

Voici une formule pour calculer le nombre total de cellules avec le mot-clé Pomme :

=NB.SI(2 $ : 13 $,“*Pomme*”)

Fonction Countif dans Google Sheets - Exemple 6 Résultat

Le critère utilisé dans l’exemple ci-dessus est *Apple*. Rythme

est un caractère générique qui représente n’importe quel nombre de caractères. Donc * Apple * compte toutes les cellules qui ont du texte Apple à côté, avec n’importe quel nombre de caractères de chaque côté.

Utilisation de COUNTIFS dans Google Sheets

= COUNTIFS (criteria_range1, condition1,[ criteria_range2, condition2,…])

COUNTIFS fonctionne de la même manière que COUNTIF, mais vous pouvez sélectionner plusieurs critères à vérifier avant de compter. La syntaxe de NB.SI.SI est la suivante :

Découvrir l\\\'article :  VHAKU d'une autre table dans Google Sheets

Comme vous pouvez le voir, c’est exactement la même chose que COUNTIF, mais avec des termes et conditions supplémentaires. Vous pouvez en ajouter autant que vous le souhaitez. Regardons un exemple pour voir comment cela fonctionne.
Dans l'exemple ci-dessous, nous devons vérifier si les personnes de l'ensemble de données ont les yeux bruns, les cheveux bruns et sont positives pour une maladie génétique.Une capture d’écran montrant les résultats de la formule COUNTIF

Nous avons utilisé la formule COUNTIFS avec plusieurs critères pour vérifier l’exigence de renvoyer 1 pour chaque résultat.

  • Conseils et dépannage de Google Sheets pour la formule COUNTIF
  • La formule COUNTIF ne peut utiliser qu’une seule condition, utilisez COUNTIFS pour plusieurs critères
  • Les arguments de texte ne sont pas sensibles à la casse

N’oubliez pas d’utiliser des guillemets dans les chaînes de texte et les opérateurs logiques

FAQ sur l’utilisation de COUNTIF dans Google Sheets

  1. Comment calculer la plage de lecture dans Google Sheets Taper =COUNTIF(
  2. dans une cellule vide où vous souhaitez afficher les résultats
  3. Mettez en surbrillance la plage que vous souhaitez calculer, puis tapez une virgule,
  4. Entrez les critères à vérifier

appuyez sur Entrée

Pouvez-vous faire un COUNTIF avec plusieurs conditions dans Google Sheets ?

Non, vous devez utiliser la formule COUNTIFS à la place. Il fonctionne de la même manière que COUNTIF, mais autorise plusieurs conditions.

Quels sont les critères pour COUNTIF ?

Vous pouvez décrire les critères sous la forme d’une instruction IF en fonction de laquelle vous souhaitez vérifier. Par exemple, si vous souhaitez compter le nombre de personnes qui ont obtenu plus de 80 points au test, vos critères peuvent être : “>80”.

Comment faire un COUNTIF avec deux feuilles de critères ?

= COUNTIFS (criteria_range1, condition1,[ criteria_range2, condition2,…])

Vous devez utiliser la fonction COUNTIFS à la place avec la syntaxe suivante :


Si vous avez trouvé ce didacticiel COUNTIF Google Sheets utile, vous aimerez peut-être également ces didacticiels :

Julien

Laisser un commentaire